initial commit
[fcgi] / perl / README
1 $Id: README,v 1.7 2001/10/04 08:08:34 skimo Exp $
2
3     Copyright (c) 1996 Open Market, Inc.
4     See the file "LICENSE.TERMS" for information on usage and redistribution
5     of this file, and for a DISCLAIMER OF ALL WARRANTIES.
6
7     Copyright (c) 1996-1998 Sven Verdoolaege
8     No additional restrictions/warranties.
9
10 This is a Fast CGI module for perl. It's based on the FCGI module
11 that comes with Open Market's FastCGI Developer's Kit, but does
12 not require you to recompile perl.
13
14 It even no longer requires perl to be compiled with sfio.
15 To compile with sfio you'll need at least perl 5.003_02 and you'll have
16 to have configured it with eg './Configure -Duseperlio -Dusesfio'.
17 (See the INSTALL file that comes with the perl distribution.)
18 To compile without sfio you'll need an even more recent perl version.
19 (perl 5.004 and up should be fine.)
20
21 See http://www.fastcgi.com/ for more information about fastcgi.
22 Lincoln D. Stein's perl CGI module also contains some information
23 about fastcgi programming.
24
25 See echo.fpl for an example on how to use this module.
26
27 To install, do the usual
28
29 perl Makefile.PL
30 make
31 make install
32
33 If you want to use the (experimental) pure perl version, that
34 doesn't require a compiler and currently only works on Unix,
35 you have to pass the --pure-perl option as in
36 "perl Makefile.PL --pure-perl".
37
38 Note that the pure version does not support Window's Named Pipes.
39 Support for Named Pipes is not a requirement of the FastCGI specification.
40 Named Pipes are used by mod_fastcgi and the FastCGI application library as a
41 replacement for Unix sockets.  mod_fastcgi uses Named Pipes on Windows (Unix
42 sockets on Unix) by default (see the mod_fastcgi docs for more information).
43
44 If you want the module to use a previously installed fcgi library
45 instead of the included files, use the --use-installed option,
46 optionally followed by the name of the directory in which it can 
47 be found.
48
49 To configure the library Makefile.PL will run ./configure .
50 You may want to run it yourself beforehand because its findings
51 may not always be correct.
52 The configure.readme file describes how to run ./configure (and only that).
53
54 If you're on a solaris system and your installed fcgi library is 2.02b
55 or earlier, you'll probably want to use the included files.
56
57 The old interface of the FCGI module installs die and warn 
58 handlers that merely print the error/warning to STDERR (the 
59 default handlers print directly to stderr, which isn't redirected 
60 in the non sfio case). I'm not very happy with the result. 
61 Suggestions welcome.
62
63 Sven Verdoolaege
64 skimo@kotnet.org